Aktuelle Änderungen - Suchen:

PmWiki (deutsch)


Englisch:

PmWiki

pmwiki.org

Voraussetzungen

Administratoren (Grundlagen)

Voraussetzungen zum Einrichten des PmWiki-Wiki-Systems:

  1. PHP 4.3 oder eine spätere Version, wobei mindestens die folgenden Erweiterungen installiert sein müssen (zu überprüfen mit phpinfo()):
    • mbstring
    • pcre
    • libxml
    • session
    • Empfohlen wird PHP 5 oder eine neuere Version.
    • Mit PHP5.5 benutzen Sie bitte die aktuelle PmWiki-Version.
  2. ein Webserver, der PHP-Skripte verarbeitet
  3. Schreibrechte für den Webserver-Account im Verzeichnisbaum von PmWiki (für das Bearbeiten von Seiten erforderlich).
  4. keine Restriktionen bezüglich der Dateierweiterungen auf dem Host (das kommt bei kostenlosen Web-Hosting-Providern vor)

PmWiki arbeitet mit den folgenden Betriebssystem/Webserver-Kombinationen zusammen:

  • Apache 1.3 oder 2.0 unter praktisch allem (Unix, Linux, Windows und Mac OS/X)
  • lighttpd (1.4.19 php-fastcgi ssl) unter Linux
  • nginx (0.8.47) on Windows
  • Microsoft Internet Information Server unter Windows
  • Linux + LiteSpeedWeb Server Standard Edition
  • appWeb (a small, php-enabled webserver) executing on a Linksys NSLU2 Network Storage Link device

Hingegen soll PmWiki nicht laufen auf:

  • Mac OS vor Mac OS X, weil kein PHP verfügbar ist
  • Specifische Release Candidate builds von PHP 5.3 für Windows könnte nicht korrekt mit Passwörtern laufen

Weitere Informationen:

  • Das (nur auf Englisch verfügbare) Kochbuch-Rezept Standalone stellt eine Möglichkeit zur Verfügung, PmWiki ohne einen Webserver wie Apache zu betreiben. PHP muss allerdings installiert sein. Der Webserver wird dann von einem PHP-Skript übernommen, der nicht die volle Funktionalität hat, aber PmWiki zum Laufen kriegt. PmWiki kann auch auf einem USB-Laufwerk betrieben werden:
  • Kochbuch-Rezept USB drive (nur auf Englisch verfügbar)
  • Kochbuch-Rezept PHP (nur auf Englisch verfügbar)

<< | Dokumentationsindex | >>


Übersetzung von PmWiki.Requirements,   Originalseite auf PmWikiDe.Requirements   —   Rückverweise

Zuletzt geändert:   PmWikiDe.Requirementsam 17.10.2015
 PmWiki.Requirementsam 11.03.2014
Bearbeiten - Versionen - Druckansicht - Aktuelle Änderungen - Suchen
Zuletzt geändert am 17.10.2015 03:17 Uhr